Lexus RC350 & RCF Forum banner
1 - 18 of 18 Posts

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #1 ·
Just got my firmware update on Wednesday, and this is what they fixed:

NAV system locking up
iPod issues
Bluetooth connectivity for Android and iPhone's

If you are experiencing these issues contact your dealer and ask for the update. It won't be released until September, but they will do it before if you complain about these issues.
 

·
Registered
Joined
·
75 Posts
GearHeadPeter.... When I was watching your video about the intake, I kept saying to myself "This looks like Phoenix, AZ" and then i read your signature... hahahah -_-
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #3 ·
GearHeadPeter.... When I was watching your video about the intake, I kept saying to myself "This looks like Phoenix, AZ" and then i read your signature... hahahah -_-
Yep, it's Phoenix, but at least it's a dry heat compared to Virginia. When I was stationed there it was so humid in the Summer.
 

·
Registered
Joined
·
1,016 Posts
I couldn't imagine living in the intense desert heat of Arizona. I'm a true Canadian.

Were you experiencing all those problems before the update?
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #5 ·
I couldn't imagine living in the intense desert heat of Arizona. I'm a true Canadian.

Were you experiencing all those problems before the update?

Yea I don't like the intense heat either, but it is a dry heat...LOL I really couldn't stand shoveling snow any longer or having Winter last forever, and then having my vehicles rust out because of road salt. At least here once the Sun goes down it's not as bad, and I don't have to shovel snow. I do use the Remote Start every day in the Summer, and I have a parking garage at work so it is not sitting in the Sun all day. I can also drive my cars all year round without having to put it away for the Winter.


I didn't see any issues with the NAV or iPod, but was constantly losing my Contact list even after it said it downloaded them. After the update I lost it again this morning. :crying:


Then I thought I should un-pair the phone and re-pair it, which is what I just did today. We'll see how that goes.
 

·
Registered
Joined
·
47 Posts
PETE:
Once again your posts offer us great service and advice, and thanks for being the beta tester on this firmware update, which I will ask for the next time I bring my RC in for anything.
Happy Motoring.
PS: I spent a week in Phoenix in July one year, and it was quite warm. Actually, it was unlike anything I had previously experienced. I imagine it's one of the few places where the remote start app gets used a lot in the summer months.
 

·
Registered
Joined
·
75 Posts
I was in Phoenix, AZ (85021) for about 7 months haha.... wow that heat of +115... when the sun was hitting me I felt as if I was baking
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #9 ·
GearHeadPeter, I also reside in the land of Hot. I'm in Gilbert. where abouts are you?
Same here. What color is your ride as I've only seen two others in Gilbert since I got mine in December? One USB and one Molten.
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #10 ·
I was in Phoenix, AZ (85021) for about 7 months haha.... wow that heat of +115... when the sun was hitting me I felt as if I was baking
I know what you mean. :crying:
 

·
Registered
Joined
·
1,404 Posts
Probably not as bad as in Dubai. I have family there and during summers it's way too hot to bring out supercars or anything high performance as the heat takes a toll on them... it's that bad.
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #12 ·
Probably not as bad as in Dubai. I have family there and during summers it's way too hot to bring out supercars or anything high performance as the heat takes a toll on them... it's that bad.

You're right the Middle East is very hot. I did a 10 month tour of duty floating on an air craft carrier, and the flight deck was about 165 degrees in the Summer, which made it suck to have to work. The sand is also super fine and gets into everything.


I just have to remind myself that there are other places that are hotter, but not many.
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #13 ·
Quick update on the firmware update. So far after un-pairing and then re-pairing the phone after the update I have not lost my Contact list, which means that today I probably will as I just jinxed myself. LOL
 

·
Registered
Joined
·
11 Posts
I couldn't imagine living in the intense desert heat of Arizona. I'm a true Canadian.

Were you experiencing all those problems before the update?
Try Virginia, believe me it's worse, I'll take the dry heat any day. But I'm all for the no shoveling. I was born in northern Sweden 300 miles from the polar circle and spent 35 years there. If I don't see another snow flake in my life I'll be ok, believe me. Once I'm done working I'll move, Virginia climate is too temperamental for me.
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #15 ·
Try Virginia, believe me it's worse, I'll take the dry heat any day. But I'm all for the no shoveling. I was born in northern Sweden 300 miles from the polar circle and spent 35 years there. If I don't see another snow flake in my life I'll be ok, believe me. Once I'm done working I'll move, Virginia climate is too temperamental for me.

I hear you. Virginia, and TN were two states where I was stationed that when I took a shower in the morning, and walked 100 ft. to my car I was soaked from all the humidity. Hated it, and you're right about the weather being temperamental. If you didn't like the weather you had wait 20 minutes and it would be different. LOL
 

·
Registered
Joined
·
2 Posts
Hey guys, had to jump in. I took my RC350 F in to Lexus of Richmond (Va) yesterday bc of connectivity issues w my Samsung 5 not playing audio (ML stereo). Today they told me to remove my personal info from the car (under settings) and then re connect. When I did that, the car did a "mandatory" update and when I reconnected, it worked! Hope this fixes everyone's problems!
 

·
Premium Member
Joined
·
310 Posts
Discussion Starter · #17 ·
Hey guys, had to jump in. I took my RC350 F in to Lexus of Richmond (Va) yesterday bc of connectivity issues w my Samsung 5 not playing audio (ML stereo). Today they told me to remove my personal info from the car (under settings) and then re connect. When I did that, the car did a "mandatory" update and when I reconnected, it worked! Hope this fixes everyone's problems!

Good to know, thanks for the tip. I've got the same phone. Before you did the delete personal info had you tried to un-pair and then re-pair the phone?
 
1 - 18 of 18 Posts
Top